29 enero, 2006

Debian Instalada

Bueno pues después de un finde instalando la Debian, probándola e instalando chorradas a mas no poder creo que va siendo hora de hacer un mini memorandum (:p) de la experiencia:
Lo primero que hice fue instalar Debian Sarge con el cd netinstall. Hasta aquí todo genial, normal y como debe ser.

...
4 horas despues
...

Entonces me dispongo a dar el salto mas importante que un linuxero puede dar,
 s/stable/unstable sobre /etc/apt/sources.list
#sed s/stable/unstable/g /etc/apt/sources.list > /etc/apt/sources.list
#apt-get update && apt-get -y dist-upgrade

La mayoría a sabe que significa eso...Pasar de estable a inestable...uff solo decirlo ya da yuyu...

...
3 horas despues
...
Todo ha ido bien. Lógico si usas apt ;-p. Ahora toca pasar del kernel 2.6.8 que tengo instalado al 2.6.15, cómo? sencillo
#apt-get install linux-image-2.6-686
A los 5 minutos aproximadamente se baja y MEEEEEGHH!!!! ERROR!!!

como que error¿?¿?¿?¿¿? fue lo primero que pense. Pues resulta que nuestro querido paquete udev esta dando por culo todo lo que puede.

Despues de mucho mete y saca paquetes sin usar apt ya que el puto udev lo dejo bloqueado caigo en la cosa de que lo unico que le falta al nuevo kernel para correr es el initrd, asi que monto el disco duro donde tenia mi instalación anterior y lo copio a capon, son un par :-)

Y FUNCIONA!!! la verdad es que estas cosas molan jeje, bueno el caso es que hice esto con un kernel 2.6.12 ya que es lo que el puto udev queria, y de ahi me instale el 2.6.15 ya que no me fiaba mucho de mi chapucilla.
Una vez tengo corriendo mi nuevo kernel instalo el putoudev.deb y el driver nvidia que funiona perfectamente.

Arranco las X y GUAU!!!la ventana de meter usuario y pass que antes tardaba3 minutos en salir ahora tarda 3 segundos!!!hombre, ya solo faltaba que despues de reinstalar siguiera igual...
Me pongo a grabar un DVD y MIRA!!!! graba al maximo!!!
Por un momento parecia que seria un dia grandioso...pero...
todo estaba mas o menos como lo tenia en la instalacion anterior ya que los /home los he conservado; y digo mas o menos porque no he instalado kwin-baghira (estilo MacOS) y la verdad me gusta Plastik con esta combinación de colores e iconos.
Bueno, que me desvio, como todo estaba como lo deje, mi querido amigo kopete quieria iniciarse pero NO ESTABA!!! no problema...
#apt-get install kopete
MEEEGGGG ERROR!!! falta la libreria libmeanwhile0...y yo pense... que mean que?!?!?!

Despues de mucho buscar me bajo un rpm que alienizo e instalo, todo perfecto, kopete se lo traga y arranca tal y como lo deje, esto parece u buen dia al fin y al cabo...pero...

Pero no todo puede ser bonito, para resumir ya que estoy cansado, decir que los problemas que tengo ahora son que no me monta los cd, dvd y mass-storage-devices automaticamente y que en el firefox tengo una franja rara debajo de la barra de estado.

En general la reinstalación ha sido fructífera en mi opinión, he arreglado muchos problemas y aunque tenga otros creo que son cuestion de tiempo y no son tan graves como los que tenía...

Asi son las cosas y así se las hemos contado, mañana mas y mejor a la misma hora en el mismo canal.

PD: En cuanto al estatut, personalmente creo (aunque muchos catalanes me lo han confirmado) que la ciudadanía catalana tiene otros problemas y muchas mas cosas importantes en que pensar que en si poner o no poner una palabrita en un papelito si al final todos sabemos/queremos/anhelamos que todo va a seguir igual....o no...

1 comentario:

laparca dijo...

Por lo menos te dejó pasar de sarge a sid. Este semana estuve con un chaval de intercambio (es un chaval de las lista, Vincent), y no me dejó. Debian decía que no, que no actualizaba.

De hecho, era culpa del udev (¡A que no te sorprende!). Decía que necesitaba un núcleo >= 2.6.12, le trataba de poner el 2.6.15 y no me dejaba, porque necesitaba yiard o initramfs (o algo parecido), pero tampoco dejaba instalarlos.

Solución, reinstalar (Vicent, si lees esto, que sepas que es culpa de la secta Debian :-P).